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Adjunct Professor

Washington University in St. Louis

“Technology in Our Changing Society”

“Web Site Management”

“Web Design” & “Advanced Web Design”

“From Blogs to Wikis:
Building Community in a Virtual Environment”

“Technology & The Law”

“Practical Security”
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What Is It?
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Editions
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Standard

Premier

Team

Education (& Nonprofits)

Partner
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Standard Premier Team Education Partner

$$$

Gmail

99% 
uptime

Storage 
per user

Ads

$0
$50/
user/yr

$0 $0
$0 / 
$0.15/user/
mo.

! ! ! !

! !

6.75 GB 25 GB 6.75 GB 6.75 GB

Standard Optional Optional
Standard / 
No
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Standard Premier Team Education Partner

Calendar

Docs

Talk

Sites

Start 
Page

24/7 
Phone 

Support

! ! ! ! !

! ! ! ! !

! ! ! ! !

! ! ! !

! ! ! ! !

! !



Setting Up
DNS
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http://www.google.com/a/
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Migrating
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Gmail
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Planning
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Mold your email folder structure
into the one used by Gmail
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2 levels of folders max

Friends

Friends/Jackie

Friends/Jackie/Project A



Don’t freak!

Simply your folders & rely on search

(& beware
of automatic migration tools)
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2 ways to migrate:

! Manually
! 2-way synchronization



Manually
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Set up IMAP at Gmail

Connect to Gmail in your mail client

Manually copy messages



Advantages

! Metadata preserved
! Control

! Automatic labeling
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Disadvantages

! Takes a loooooong time
! Tedious
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Gmail collapses threads
into conversations

You transfer 5000 messages

Gmail reports 2000 conversations

Don’t panic
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Sync
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If you use
the Premier or Education Editions,

you can use Google’s free
IMAP Migration Tool



Automatically migrate mbox file

2gmail.rb mboxfile GmailFolder 
[StartingMessage]

"

2gmail.rb WebSanity
Work/WebSanity
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Thunderbird
+

WebMail Extension

Allows you to migrate email from:
! Hotmail
! Yahoo
! Gmail
! AOL

! & others

41



Other solutions for webmail

! FreePOPs
! MacFreePOPs !

! YPOPs
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OS T-bird

Mail Redirect 
Extension !



Contacts

44



45

2 ways to import:

! Manually via CSV
! 2-way synchronization



Gotchas

! Records must have
unique email addresses

! ~3,000 contacts at a time
! You can’t transfer groups or lists
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CSV
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Google tries to work
with default CSV exports,

but you may have to massage it

Test with a few contacts first!
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Most basic CSV file

! Name
! Email
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Create a contact
in Google Contacts,

export it,
& examine the CSV file
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Evolution

evolution-addressbook-export -
format=csv -output=~/evolution.csv
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KAddressBook

File > Export

52



Thunderbird

Address Book: Tools > Export

53



Once you have your CSV file,
go to Google Contacts

Import
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Sync
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OS
Apple 

Address 
Book

Outlook T-bird

Plaxo

Spanning 
Sync

Zindus T-bird 
Calendar Sync

! !

!

!



Calendar
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2 ways to import:

! Manually via ICAL or CSV
! 2-way synchronization



Manual
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Gotchas with CSV

! Recurring events become
a series of individual events
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Apple iCal

File > Export

61



Evolution

No export?!?

~/.evolution/calendar/
local/system/calendar.ics
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KOrganizer

File > Export > iCalendar
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Sunbird
OR

Thunderbird with Lightning

File > Export Calendar
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Sync
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OS iCal Evolution T-bird Outlook

ScheduleWorld

Spanning Sync

GCALDaemon

Provider (T-
bird extension)

! ! ! !

!

! ! !

!



Gmail
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Settings
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Search
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Headers

to:

cc:

bcc:

subject:

from:



Attachments

has:attachment

filename:pdf
(or csv, odt, ppt, rtf, txt, xls)

filename:mpg
(or avi, mov, mp4, wmv)

filename:mp3
(or wav, wmv)

filename:jpg
(or bmp, gif, png, tiff)
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Labels
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Search Shortcut Shortercut Shortestcut

label:inbox

label:starred

label:sent

label:spam

in:inbox l:inbox l:^i

in:starred l:starred l:^t

in:sent l:sent l:^f

in:spam l:spam l:^s



Time

after:2008/12/5

before:2008/12/5
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Booleans & Symbols

AND or (space)

OR or |

NOT or -

“”
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Integrating
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Read Gmail via POP or IMAP

! Apple Mail
! Evolution
! KMail

! Thunderbird

! iPhone
! Blackberry



Making Gmail the default
on your Linux box
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In Firefox

about:config in the address bar

Set
network.protocol-handler.external.mailto

to true
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#!/bin/sh
BROWSER=”firefox” 

# remove the ? from the uri
uri=`echo “$1” | sed -e ‘s/subject=/su=/’ -e ‘s/
^mailto:\([^&?]\+\)[?&]\?\(.*\)$/\1\&\2/’` 

if [ “$uri” ]; 
  then exec $BROWSER 
“https://mail.google.com/a/YOURDOMAIN/?
view=cm&tf=0&ui=1&to=$uri” 
fi 

exec $BROWSER “https://mail.google.com/”
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Download the script from
http://ftp.granneman.com/

googleapps/gmail_default.sh
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Save script to ~/bin

chmod 755 ~/bin/gmail_default.sh
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GNOME

System > Preferences
> Preferred Applications > Internet

> Mail Reader

 In Custom, enter:

/home/USER/bin/gmail_default.sh
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KDE

System Settings >
Default Applications > Email Client

> Use a Different Email Client

Enter:

/home/USER/bin/gmail_default.sh
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Contacts
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You can’t delete
more than 20 contacts at a time

Solution:



Calendar
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Integrating
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Read-Only Access
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Evolution

File > New > Calendar

View,
but can’t add, edit, or delete events



iCal

Calendar > Subscribe
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KOrganizer

Settings > Sidebar >
Show Resource View

Add > Calendar in Remote File

View,
but can’t add, edit, or delete events
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Sunbird
OR

Thunderbird with Lightning

Calendars > New Calendar
> On the Network
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Syncing
with Spanning Sync

or BusySync



Sync
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OS iCal Evolution T-bird Outlook

ScheduleWorld

Spanning Sync

GCALDaemon

Provider (T-
bird extension)

! ! ! !

!

! ! !

!



Docs
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Templates
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Some useful templates

! Comprehensive Travel Itinerary
! Gas Mileage Log

! Wedding Album, Guest List, 
Planner, Budget Manager, Checklist

! Sales Invoice
! Video Christmas Card

! Budget Planner
! Presentations



Gears
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Use Google Gears to go offline

113



Use Google Gears to go offline
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Use Google Gears to go offline
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Publishing
&

Sharing
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Formulas
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From Jans’ D&D website
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Insert the ImportHtml function
into your spreadsheet

=ImportHtml(URL, Query, Index)

Query = List or Table

=ImportHtml(“http://www.d20srd.org/
srd/combat/combatStatistics.htm”, 

“table”, 1)
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#



Forms

121



122



123



124

Question types

! Text
! Paragraph text
! Multiple choice
! Check boxes

! Choose from a list
! Scale (1-n)
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Integrating
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OpenOffice.org

OoGdocsIntegrator
extensions.services.openoffice.org/

project/OoGdocsIntegrator

OpenOffice.org2GoogleDocs
extensions.services.openoffice.org/

project/ooo2gd
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OpenOffice.org2GoogleDocs
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Firefox

Send to Google Docs extension
addons.mozilla.org/en-US/

firefox/addon/8552

Google Toolbar for Firefox
toolbar.google.com

gDocsBar extension
addons.mozilla.org/en-US/

firefox/addon/6363
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Backing Up

131



Gmail

132
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getmail, a better fetchmail

http://pyropus.ca/software/getmail/

Free & open source

POP3 over SSL & IMAP over SSL



Matt Cutt’s
“How to back up your Gmail
on Linux in four easy steps”

http://www.mattcutts.com/blog/
backup-gmail-in-linux-with-getmail/

134



Contacts
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Synchronize with:

! Plaxo
! Zindus Thunderbird Contact Sync

! GCALDaemon
! Spanning Sync !



Calendar
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Synchronize with:

! ScheduleWorld
! GCALDaemon

! Spanning Sync !
! CalDAV !



Docs
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Automated & scriptable

Gdatacopier
http://code.google.com/p/gdatacopier

Python, CLI, & cron
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Manual

Greasemonkey Firefox extension
+

Google Docs Download
http://1st-soft.net/gdd/

+
DownThemAll Firefox extension



Sites
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wget -r -v -p -w 7 --random-wait --
cut-dirs=5 -nH -E -k -np --no-check-
certificate -D sites.google.com -X /

support -R 
compare*,revisions*,createPage* -np 
--http-user="you@yourdomain.com" 

https://sites.google.com:443/a/
yourdomain.com/yourwiki/



vim ~/.wgetrc

http_password = 123456
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Thank you!

Email: scott@granneman.com

Web: www.granneman.com

Publications: www.granneman.com/pubs

Blog: blog.granneman.com

Blog: www.1and100zeroes.com
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Licensing of this work

This work is licensed under the Creative Commons Attribution-ShareAlike 
License.

To view a copy of this license, visit
    http://creativecommons.org/licenses/by-sa/1.0
or send a letter to Creative Commons, 559 Nathan Abbott Way, Stanford, 
California 94305, USA.

In addition to the rights and restrictions common to all Creative Commons 
licenses, the Attribution-ShareAlike License features the following key 
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Attribution. The licensor permits others to copy, distribute, display, and 
perform the work. In return, licensees must give the original author 
credit.

Share Alike. The licensor permits others to distribute derivative works 
under a license identical to the one that governs the licensor’s work.
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